Skip to main content

Dynamics NAV - [ERROR] Could not Connect to FTP / FluentFTP Connection Failed

FTP connection failures in Dynamics NAV after a server restart, including how to distinguish between standard FluentFTP and Cloud FTP Bridge setups and resolve the issue.

Written by Micah A. Parker

Product: Dynamics NAV


Issue: When attempting to run inbound or outbound file transfers within Dynamics NAV, the system fails to connect to the FTP server and presents a FluentFTP connection failure.

Reason: The FTP connection failure is caused by either the fluentftp.dll file being missing or improperly configured in the standard NAV FTP setup

This error is usually a result of a System Modification on your hosted NAV Environment. It is recommended to reach out to your System Administrator prior to contacting TrueCommerce - as our support will be limited


Solution - Confirm FTP Configuration


You can confirm that the TrueCommerce Add-On is utilizing the built-in FTP solution by accessing the FTP Configuration found under the EDI Adminstration settings.

Navigate: Departments → TrueCommerce → EDI (select) → Administration → EDI Setup

Confirm: Use FTP is checked (if not, FTP is disabled)

Confirm: Username/Password

Testing the FTP Connection

You can perform a quick test to make sure your credentials and NAV client is able to connect to the system within the configuration window

Navigate: Actions → Test FTP URL


Solution - Check for Blocked FTP Ports


As security requirements continue to tighten, it's not uncommon to have common relied upon Ports that allow internet traffic to occur and pass data to be blocked. Check your with your System Administrator or Value-Added Reseller (VAR) on whether or not your environment has blocked ports for FTP (20 & 21 for standard - 22 for SFTP) as this will prevent the TrueCommerce NAV Extension from accessing the FTP.


Solution - Verify FluentFTP Installation


The TrueCommerce Extension (version 9.00.2.70 and above) requires the FluentFTP.dll file to be installed on your NAV server as a Control Add-In in order to perform FTP calls. If this file is missing, FTP will fail to connect.

Search For: Control Add-Ons

Locate: FluentFTP

If the FluentFTP Add-In is missing, it will need to be reinstalled as a Control Add-In within NAV. For full installation steps, refer to the FTP configuration article linked below.

Additional Resources


rev 09/17/26

Did this answer your question?